Make doc installation work and simplify doc/Makefile.am.
[free-sw/xcb/libxcb] / doc / Makefile.am
index 4b0ec90..f46f0b1 100644 (file)
@@ -3,38 +3,29 @@ EXTRA_DIST = \
 tutorial/index.html \
 tutorial/xcb.css
 
-if BUILD_DOCS
+htmlDATA_INSTALL = cp -pR
 
-# install documentation
+html_DATA = tutorial/
 
-all-local: doc-build.stamp
+uninstall-htmlDATA:
+       @$(NORMAL_UNINSTALL)
+       @list='$(html_DATA)'; for p in $$list; do \
+         f=$(am__strip_dir) \
+         echo " rm -rf '$(DESTDIR)$(htmldir)/$$f'"; \
+         rm -rf "$(DESTDIR)$(htmldir)/$$f"; \
+       done
+       rmdir "$(DESTDIR)$(htmldir)/" || true
 
-# rule to remove all old created files
-doc-prepare.stamp:
-       @if test -d manual/ ; then \
-         rm -rf manual/; \
-       fi
+if BUILD_DOCS
 
 # rule to build documentation and copy necessary files
-doc-build.stamp: doc-prepare.stamp
-       @cd .. && doxygen xcb.doxygen
+manual: clean-local
+       cd .. && doxygen xcb.doxygen
 
 # rules to clean
 clean-local:
-       @rm -rf manual/
-
-install-data-local: install-html-local
-
-# rule to install the html documentation and tutorial in $(htmldir)
-install-html-local:
-       @if ! test -d "$(DESTDIR)$(htmldir)"; then \
-         $(mkinstalldirs) "$(DESTDIR)$(htmldir)"; \
-       fi
-       @cp -pr manual/ "$(DESTDIR)$(htmldir)"
-       @cp -pr tutorial/ "$(DESTDIR)$(htmldir)"
+       rm -rf manual/
 
-# rule to uninstall the documentation
-uninstall-local:
-       @rm -rf $(DESTDIR)$(htmldir)
+html_DATA += manual/
 
 endif